<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->

<head>
<meta charset="UTF-8" />

<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="https://bartonchronicle.com/wp-content/themes/chronicle/style.css" />
<!--[if IE]>
<link rel="stylesheet" type="text/css" href="http://bartonchronicle.com/wp-content/themes/chronicle/ie8-9.css" />
<![endif]-->
<!--[if lt IE 9]>
<script src="https://bartonchronicle.com/wp-content/themes/chronicle/js/html5.js" type="text/javascript"></script>
<![endif]-->
<link rel="stylesheet" id="wp-forecast-css" href="https://bartonchronicle.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" />

<!-- This site is optimized with the Yoast SEO plugin v4.5 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Obituaries June 28, 2017 - Barton Chronicle Newspaper</title>
<link rel="canonical" href="https://bartonchronicle.com/obituaries-june-28-2017/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Obituaries June 28, 2017 - Barton Chronicle Newspaper" />
<meta property="og:description" content="Peter Fagan Peter Fagan, 85, of Beebe Plain, died on June 23, 2017, in Lebanon, New Hampshire. He was born on January 18, 1932, in Brighton, Massachusetts, to the late Joseph P. Fagan and Rose (Loughman) Fagan. Mr. Fagan served &hellip; Continue reading &rarr;" />
<meta property="og:url" content="https://bartonchronicle.com/obituaries-june-28-2017/" />
<meta property="og:site_name" content="Barton Chronicle Newspaper" />
<meta property="article:tag" content="curtis-britch" />
<meta property="article:tag" content="death" />
<meta property="article:tag" content="funeral" />
<meta property="article:tag" content="Linda Colleen Norris" />
<meta property="article:tag" content="obits" />
<meta property="article:tag" content="obituaries" />
<meta property="article:tag" content="Peter Fagan" />
<meta property="article:tag" content="Sidney Ames Huguenin Jr." />
<meta property="article:section" content="Obituaries" />
<meta property="article:published_time" content="2017-06-26T15:33:54+00:00" />
<meta property="article:modified_time" content="2017-06-26T15:34:01+00:00" />
<meta property="og:updated_time" content="2017-06-26T15:34:01+00:00" />
<meta property="og:image" content="https://bartonchronicle.com/wp-content/uploads/obit-Fagan-240x300.jpg" />
<meta property="og:image" content="https://bartonchronicle.com/wp-content/uploads/obit-Huguenin-300x300.jpg" />
<meta property="og:image" content="https://bartonchronicle.com/wp-content/uploads/obit-Norris-226x300.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Barton Chronicle Newspaper &raquo; Feed" href="https://bartonchronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Barton Chronicle Newspaper &raquo; Comments Feed" href="https://bartonchronicle.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/bartonchronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=ff141972d2289c236313b80ee3b30347"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='portfolio_slideshow-css'  href='https://bartonchronicle.com/wp-content/plugins/portfolio-slideshow/css/portfolio-slideshow.min.css?ver=1.5.1' type='text/css' media='screen' />
<link rel='stylesheet' id='theme-my-login-css'  href='https://bartonchronicle.com/wp-content/plugins/theme-my-login/theme-my-login.css?ver=6.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='wpcomments-styles-css'  href='https://bartonchronicle.com/wp-content/plugins/wp-comment-fields/plugin.styles.css?ver=ff141972d2289c236313b80ee3b30347' type='text/css' media='all' />
<link rel='stylesheet' id='wpcomments-bootstrap-grid-css'  href='https://bartonchronicle.com/wp-content/plugins/wp-comment-fields/assets/css/bootstrap-grid.css?ver=ff141972d2289c236313b80ee3b30347' type='text/css' media='all' />
<link rel='stylesheet' id='A2A_SHARE_SAVE-css'  href='https://bartonchronicle.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.13' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.1.5 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	// Function to detect opted out users
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	// Disable tracking if the opt-out cookie exists.
	var disableStr = 'ga-disable-UA-15213276-1';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	// Opt-out function
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-15213276-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wp-forecast/wpf_update.js?ver=9999'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/sam-pro-free/js/jquery.iframetracker.js?ver=ff141972d2289c236313b80ee3b30347'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var samProOptions = {"au":"https:\/\/bartonchronicle.com\/wp-content\/plugins\/sam-pro-free\/sam-pro-layout.php","load":"0","mailer":"0","clauses":"VWaLvScqm8cZZlnMcSsibgMYNeqNJFfEbqJ8+HoFzcCMRvN8nwrIQhTow+ApT8gmj\/Jy6tLmWZhosA7UZr1ouzX0XnGRqc3r2AOl9QWNxiCJ5pKk6Tmthc7wHP7cjmgAtuqgmppQUEi7Va84tHjgYgQRQdSF3+Hp+FvksHuBv+s5gIJoZtAkXf7Ym9GoWnuyzGKL0dOBgh00RXbOgjA+3DSRqT9kEWq5n4OSXBOf7qFSBJQQM0yAE99aoyLAH1zgk0f5kNSz1A9eR0jJChaG0GODKKqp\/sgJCzeaRMOG20TEz19rMPfgPQevg6HnW5oOZnUn351A+LuSHZ8JRmPfptn\/2AxshFMg2sIqz6CWBgfboBf1b+MalUlgMqWOKx9KGPR9L3jPd8nwM4CKapme41uWwAvomVSwOnIhgdjMX6ZvtLpgSUf+styGhL1qM8UD7nlWPxc5ZVXL+qkmIk5OCuibX\/AAO0aMvOpNNOPRWk8bhQPlhKe\/4rfpZEA5xyoJG9+bBpLqzjYMM3aqRdSyKXOuApqIyPPtIBCGutl9Ov8NHVZ38+7BftUv+W2LSV9+AHFXaAafWj\/of7GjfJifyo4L2ezJNMTfZZf9+B+z1emlUqv0XHQly2EpCcGsEMSrzoFQdWKPMpQyOtMp2GDih8S2oXNaSbv9RsB5kMkNPeY6E3tSl9aPTq\/5PGoFe3rVmRBnssRB4IOedj0Z5yC5pdkIcKP7E2fm3kxlNBHJWN4a2uqDyZI5YQKIDsId25058KSRdzMNDGwjw5yvve9P0R7m8W2+iCIQZC66XIqD+3vCkX8bysxf16y6xDqnkZ6MgsJ7LmaUbTmXmCor2Ib\/68EoDg8lssHb+wMzpL3vQwulk\/oRVaDlo\/3cATuckrPUCHc86WBl8430QOZRE4xPFZtWb8OWnnZR\/Wvenek1YfALIFvLaCb2qwFKmz7C6aIYmYXOj\/gFpoNha51qRFS1D4LOUiQsDnw+jfu\/nNLsHEk=","doStats":"0","jsStats":"","container":"sam-pro-container","place":"sam-pro-place","ad":"sam-pro-ad","samProNonce":"707ebcbf59","ajaxUrl":"https:\/\/bartonchronicle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/sam-pro-free/js/sam.pro.layout.min.js?ver=1.0.0.10'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/theme-my-login/modules/themed-profiles/themed-profiles.js?ver=ff141972d2289c236313b80ee3b30347'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomments_vars = {"ajaxurl":"https:\/\/bartonchronicle.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/bartonchronicle.com\/wp-content\/plugins\/wp-comment-fields","settings":{"bug":"false","wpcomments_comment_heading":"","wpcomments_comment_posttypes":"","action":"wpcomments_save_settings"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wp-comment-fields/js/script.js?ver=ff141972d2289c236313b80ee3b30347'></script>
<link rel='https://api.w.org/' href='https://bartonchronicle.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bartonchronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bartonchronicle.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://bartonchronicle.com/?p=30847' />
<link rel="alternate" type="application/json+oembed" href="https://bartonchronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbartonchronicle.com%2Fobituaries-june-28-2017%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://bartonchronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbartonchronicle.com%2Fobituaries-june-28-2017%2F&#038;format=xml" />

<script type="text/javascript">
var a2a_config=a2a_config||{};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.templates=a2a_config.templates||{};
</script>
<script type="text/javascript" src="https://static.addtoany.com/menu/page.js" async="async"></script>

<!-- Portfolio Slideshow-->
<noscript><link rel="stylesheet" type="text/css" href="https://bartonchronicle.com/wp-content/plugins/portfolio-slideshow/css/portfolio-slideshow-noscript.css?ver=1.5.1" /></noscript><script type="text/javascript">/* <![CDATA[ */var psTimeout = new Array();  var psAutoplay = new Array();  var psFluid = new Array(); var psTrans = new Array(); var psSpeed = new Array(); var psLoop = new Array();/* ]]> */</script>
<!--//Portfolio Slideshow-->
<!-- rp news ticker support --><style>#rpliscrollticker {display:none;}
.tickercontainer {background: #fff;width: 100%; height: 22px;margin: 0;padding: 0;overflow:hidden;}
.tickercontainer .mask { position: relative;left: 5px;top: 5px;width: 98%;overflow: hidden;}
ul.newsticker {position: relative;left: 750px;font: bold 10px Verdana;list-style-type: none;margin: 0;padding: 0;}
ul.newsticker li {float: left; margin: 0;padding: 0;background: #fff;}
ul.newsticker {width:1100px;}
ul.newsticker a {white-space: nowrap;padding: 0;font: bold 12px Verdana;margin: 0 30px 0 0;}
ul.newsticker span {margin: 0 10px 0 0;}</style><script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {$("#rp-news-ticker").show().liScroll({travelocity: 0.09});});
//]]>
</script><!-- /rp news ticker support -->
	<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//bartonchronicle.com/?wordfence_logHuman=1&hid=205031614C0A3DC764324CC786DBD949');
</script>	<style type="text/css">
			#site-title,
		#site-description {
			position: absolute !important;
			clip: rect(1px 1px 1px 1px); /* IE6, IE7 */
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	</head>

<body class="post-template-default single single-post postid-30847 single-format-standard singular two-column right-sidebar">
<div id="page" class="hfeed">
	<header id="branding" role="banner">
			
<div class="widget-area" role="complementary">
					<aside id="sam_pro_place_widget-2" class="widget sam_pro_place_widget"><div id='c7840_53_1' class='sam-pro-container sam-pro-place'><a id='img-53-7840' class='sam-pro-ad' href='http://www.ccv.edu?utm_campaign=SPR17&utm_medium=ldboard&utm_source=barton&utm_content=facts' target='_blank'><img src='https://bartonchronicle.com/wp-content/uploads/20170429_fact728x90.gif' ></a></div></aside>				</div><!-- .widget-area -->
                
						<a href="https://bartonchronicle.com/">
									<img src="https://bartonchronicle.com/wp-content/uploads/Chronicle-logo21.jpg" width="1000" height="188" alt="" />
							</a>
			
							<div class="only-search with-image">
				
					<form method="get" id="searchform" action="https://bartonchronicle.com/">
		<label for="s" class="assistive-text">Search</label>
		<input type="text" class="field" name="s" id="s" placeholder="Search" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
				</div>
			<div id="topper"><a href="http://bartonchronicle.com/chronicle-online-edition"><img src="/wp-content/uploads/OE-Blue-Button.gif"></a>
<a href="http://bartonchronicle.com/tipline/"><img src="/wp-content/uploads/tipline.jpg"></a></div>
			
			<nav id="access" role="navigation">
				<h3 class="assistive-text">Main menu</h3>
								<div class="skip-link"><a class="assistive-text" href="#content" title="Skip to primary content">Skip to primary content</a></div>
				<div class="skip-link"><a class="assistive-text" href="#secondary" title="Skip to secondary content">Skip to secondary content</a></div>
								<div class="menu-main-nav-container"><ul id="menu-main-nav" class="menu"><li id="menu-item-15393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-15393"><a href="https://bartonchronicle.com/">Home</a></li>
<li id="menu-item-15398" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15398"><a href="https://bartonchronicle.com/events/">Kingdom Calendar of Events</a>
<ul  class="sub-menu">
	<li id="menu-item-19728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19728"><a href="https://bartonchronicle.com/submit-event/">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-27716" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-27716"><a href="https://bartonchronicle.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-18326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18326"><a href="https://bartonchronicle.com/category/sports-news/">Sports</a></li>
<li id="menu-item-15394" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15394"><a href="https://bartonchronicle.com/classifieds/">Classifieds</a></li>
<li id="menu-item-76" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76"><a href="https://bartonchronicle.com/chronicle-online-edition/">Online Edition</a></li>
<li id="menu-item-15397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15397"><a href="https://bartonchronicle.com/ad-rates/">Advertise</a>
<ul  class="sub-menu">
	<li id="menu-item-16621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16621"><a href="https://bartonchronicle.com/submit-classifieds/">Submit Classifieds</a></li>
	<li id="menu-item-16619" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16619"><a href="https://bartonchronicle.com/submit-website-ad/">Submit Website Ad</a></li>
	<li id="menu-item-16620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16620"><a href="https://bartonchronicle.com/submit-print-ad/">Submit Print Ad</a></li>
</ul>
</li>
<li id="menu-item-16590" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-16590"><a href="#">Subscribe</a>
<ul  class="sub-menu">
	<li id="menu-item-15396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15396"><a href="https://bartonchronicle.com/print-subscriptions/">Print Subscription</a></li>
	<li id="menu-item-16591" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16591"><a href="https://bartonchronicle.com/create-online-subscription">Create Annual  Online Subscription</a></li>
	<li id="menu-item-21478" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21478"><a href="https://bartonchronicle.com/create-short-term-online-subscription/">Create Short Term Online Subscription</a></li>
</ul>
</li>
<li id="menu-item-15395" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15395"><a href="https://bartonchronicle.com/contact-us/">Contact Us</a>
<ul  class="sub-menu">
	<li id="menu-item-16639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16639"><a href="https://bartonchronicle.com/chronicle-staff-bios/">Chronicle staff bios</a></li>
</ul>
</li>
</ul></div>			</nav><!-- #access -->
	</header><!-- #branding -->


	<div id="main">
		<div id="primary">
			<div id="content" role="main">
	<div id="first" class="widget-area" role="complementary">
		<aside id="text-5" class="widget widget_text"><h3 class="widget-title">This Week&#8217;s Headlines:</h3>			<div class="textwidget"></div>
		</aside>        <ul id="rp-news-ticker">
            <li><a href="https://bartonchronicle.com/this-weeks-headlines/">Overdose awareness walk in Newport...</a></li>
<li><a href="https://bartonchronicle.com/this-weeks-headlines/">Sugaring nears historic levels...</a></li>
<li><a href="https://bartonchronicle.com/this-weeks-headlines/">Wandering elk are back home...</a></li>
<li><a href="https://bartonchronicle.com/this-weeks-headlines/">Barton solar project could raise rates...</a></li>        </ul>
        <aside id="text-6" class="widget widget_text">			<div class="textwidget">
</div>
		</aside>	</div><!-- #first .widget-area -->
					
					<nav id="nav-single">
						<h3 class="assistive-text">Post navigation</h3>
						<span class="nav-previous"><a href="https://bartonchronicle.com/newport-reappraisal-lead-drop-tax-rate/" rel="prev"><span class="meta-nav">&larr;</span> Previous</a></span>
						<span class="nav-next"><a href="https://bartonchronicle.com/wandering-elk-safely-back-home/" rel="next">Next <span class="meta-nav">&rarr;</span></a></span>
					</nav><!-- #nav-single -->

					
<article id="post-30847" class="post-30847 post type-post status-publish format-standard hentry category-obituaries tag-curtis-britch tag-death tag-funeral tag-linda-colleen-norris tag-obits tag-obituaries-2 tag-peter-fagan tag-sidney-ames-huguenin-jr">
	<header class="entry-header">
		<h1 class="entry-title">Obituaries June 28, 2017</h1>

				<div class="entry-meta">
			<span class="sep">Posted on </span><a href="https://bartonchronicle.com/obituaries-june-28-2017/" title="3:33 pm" rel="bookmark"><time class="entry-date" datetime="2017-06-26T15:33:54+00:00" pubdate>June 26, 2017</time></a><span class="by-author"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="https://bartonchronicle.com/author/editor/" title="View all posts by editor" rel="author">editor</a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

	<div class="entry-content">
		<p style="text-align: center;"><strong><a href="https://bartonchronicle.com/obituaries-june-28-2017/obit-fagan/" rel="attachment wp-att-30848"><img class="alignleft size-medium wp-image-30848" src="https://bartonchronicle.com/wp-content/uploads/obit-Fagan-240x300.jpg" alt="" width="240" height="300" srcset="https://bartonchronicle.com/wp-content/uploads/obit-Fagan-240x300.jpg 240w, https://bartonchronicle.com/wp-content/uploads/obit-Fagan-440x550.jpg 440w, https://bartonchronicle.com/wp-content/uploads/obit-Fagan.jpg 713w" sizes="(max-width: 240px) 100vw, 240px" /></a>Peter Fagan</strong></p>
<p>Peter Fagan, 85, of Beebe Plain, died on June 23, 2017, in Lebanon, New Hampshire.</p>
<p>He was born on January 18, 1932, in Brighton, Massachusetts, to the late Joseph P. Fagan and Rose (Loughman) Fagan.</p>
<p>Mr. Fagan served in the United States Coast Guard from 1949 to 1952 stationed in Cape May, New Jersey, Boston, Massachusetts, and Greenland. In 1952 he enlisted in the United States Air Force, completing basic training at Sampson Air Force Base in New York and later was stationed in California; Mississippi; New Mexico; Truro, Massachusetts; Thule, Greenland; and finally at Otis Air Force Base, in Massachusetts, where he served  until his retirement in 1969.</p>
<p>On September 21, 1956, he married Corwyn Lorimer. They were happily married for nearly 61 years.</p>
<p>After his retirement from the Air Force, Mr. Fagan worked as a security guard at Woods Hole Oceanographic Institute in Woods Hole, Massachusetts, and at Cardinal Cushing Hospital in Brockton, Massachusetts. In 1973, Mr. Fagan moved with his family to Beebe Plain, and worked for five years at Sacred Heart High School in Newport. In 1979, he began working at North Country Union High School as a custodial manager until his retirement in 2004.</p>
<p>Mr. Fagan was a member of the Civil War Round Table, Gold Wing Road Riders Club, and a member of the Derby Community Church for the past 40 years, as well as a board member of the Derby Historical Society.</p>
<p>He was very interested in his genealogy and visited Ireland with his brother John twice, researching his family tree.</p>
<p>Mr. Fagan bought his first kayak in Old Town, Maine, and participated in his first whitewater race in 1978, winning a trophy as the oldest competitor when he was 46. He owned his first motorcycle in 1955 and owned many more throughout his life. His drove his motorcycle for the last time in 2016 at the age of 84.</p>
<p>He was an avid sports fan. He loved the New England Patriots, the Boston Bruins, and especially the Boston Red Sox. He also loved bird watching, gardening, history, astrology, news, fishing, hunting, bowling, cooking for his family, and the men’s breakfast every Wednesday morning at the Derby Community Church. He was an avid reader of science and historic events. He was a wonderful dancer, and he and his wife were the first and last couple on the dance floor at every wedding and event with music.</p>
<p>He was known to his grandchildren and great-grandchildren as Papa. The love he had for his grandchildren will live deeply inside each one of them. He told many amazing stories of his life, and his adventures with his family and everyone he met. His stories will always be cherished. He was such a loving and selfless man, always willing to help others. He taught many life lessons from how to paddle a canoe to the importance of history. Family was always the most important thing in his life and during his last goodbyes to family members he shared how proud he was of them all.</p>
<p>Mr. Fagan was an inspiration to all his family. He taught them all to be lifelong learners, to admire nature, to help others in need, to enjoy travel, savor great food, and to always have a strong work ethic.</p>
<p>He is survived by his wife of 61 years, Corwyn Fagan; his canine companion, Buster; his daughters: Laurie Locke and her husband, Jeff, of East Albany, Mona Rapini and her husband, Mark, of Bellows Falls, and Melanie Farrow and her husband Mike, of Holland. He is also survived by his grandchildren: Christopher Rapini, Amanda Sargent, Nicholas Rapini, Shannon Hamblett, Iris Locke, Benjamin Farrow, Tristan Farrow; six great-grandchildren; as well as brother Paul Fagan and his wife, Lou; his brother-in-law Collyn Lorimer and his wife, Josie; his sister-in-law Leah Kittredge; and brother-in-law Bruce Lorimer; and numerous nieces and nephews.</p>
<p>He was predeceased by his great grandson Cole Rapini; brothers: Thomas Fagan and his wife, Barbara, John Fagan and his wife, Marguerite, Francis Fagan and his wife, Doris, Joseph Fagan, and Lawrence Fagan; and his sister Mary Cavicchi. He was also predeceased by his in-laws: Stella McCormick, Audrey Webb and her husband, Henry, Rodney Lorimer and his wife, Joanne, and Wendell Lorimer and his wife, Betty.</p>
<p>Friends may call on Friday, June 30, from 6 to 8 p.m., at the Curtis-Britch-Converse-Rushford Funeral Home, 4670 Darling Hill Road, Newport. Funeral services will be held at 11 a.m., on Saturday, July 1, at the Derby Community Church in Derby. Interment will follow at the Derby Center Cemetery on Nelson Hill Road in Derby.</p>
<p>Should friends desire, contributions in his memory may be made to the Derby Historical Society, in care of Alan Yale, 913 Bridge Street, Derby, Vermont 05829; or to the Derby Community Church, in care of Michael Haddad, 3064 U.S. Route 5, Derby, Vermont 05829.</p>
<p>Online condolences can be shared at Curtis-britch.com.</p>
<p>&nbsp;</p>
<p style="text-align: center;"><strong><a href="https://bartonchronicle.com/obituaries-june-28-2017/obit-huguenin/" rel="attachment wp-att-30849"><img class="alignleft size-medium wp-image-30849" src="https://bartonchronicle.com/wp-content/uploads/obit-Huguenin-300x300.jpg" alt="" width="300" height="300" srcset="https://bartonchronicle.com/wp-content/uploads/obit-Huguenin-300x300.jpg 300w, https://bartonchronicle.com/wp-content/uploads/obit-Huguenin-150x150.jpg 150w, https://bartonchronicle.com/wp-content/uploads/obit-Huguenin-550x550.jpg 550w, https://bartonchronicle.com/wp-content/uploads/obit-Huguenin.jpg 713w" sizes="(max-width: 300px) 100vw, 300px" /></a>Sidney Ames Huguenin Jr.</strong></p>
<p>Lieutenant Colonel Sidney Ames Huguenin, Jr., 90, of Brownington, died June 10, 2017, at North Country Hospital in Newport.</p>
<p>Mr. Huguenin was born on April 23, 1927, in Pittsburgh, Pennsylvania, to Sidney Ames Huguenin and Harriet Theodora Wanzer Huguenin. As the son of a Naval officer, he moved frequently and attended schools in Wilmette, Illinois, New Trier, Illinois, Chappaqua, New York, and Santa Cruz, California. In 1945, he graduated from high school and immediately enlisted in the U.S. Navy. When World War II soon ended, he was mustered out and attended the University of California at Berkeley, graduating with a bachelor’s degree in 1949.</p>
<p>When the conflict in Korea began, he attended Officer Candidate School and was commissioned as a second lieutenant in the U.S. Marine Corps in 1952. He fought in Korea as a tank platoon commander, receiving the Navy Commendation Medal with V device for valor. He spent the next 20 years as a career Marine officer serving in various capacities around the world. The last few years of his career were spent at the Pentagon and Headquarters Marine Corps.</p>
<p>He retired in 1971 and moved his family to Brownington, where he and his wife, Joan, became active in the community, serving on the local school board and the Old Stone House board. He also enjoyed skiing regularly at Jay Peak, as well as going to Tuckerman’s Ravine several times in the spring, walking up with skis on his back and skiing down treacherous terrain. Mr. Huguenin was an avid reader and outdoorsman.</p>
<p>He is survived by his wife of 50 years, Joan Doherty Huguenin; his daughter Bridget Theodora Huguenin of St. Albans; and, from his previous marriage to Katherine Kohler Huguenin, by his son Sidney A. Huguenin III and his wife, Mary Jo Huguenin, of Hagerstown, Maryland, his daughter Anne Wright Huguenin and her husband, Chuck Horne, of Atlanta, Georgia; his grandsons Sidney A. Huguenin IV and his wife, Lauren Wright Huguenin, of Hagerstown, Brian W. Huguenin and his fiancée, Vicki Donnick, of Baltimore, Maryland, and Nick Horne and his wife, Melissa Horne, of Atlanta; and great-grandson Charles Theodore Huguenin of Hagerstown.</p>
<p>In addition to his parents, he was predeceased by his sisters: Sarah Jean Huguenin, Virginia H. Carson, and Harriet H. MacDonald, and his son James Philip Bennett Huguenin.</p>
<p>In lieu of flowers, please consider donating to the Old Stone House Museum, 109 Old Stone House Road, Brownington, Vermont 05860. He did not wish to have a formal funeral, and the family will gather from around the country at a later date.</p>
<p>Online condolences may be shared at curtis-britch.com.</p>
<p>&nbsp;</p>
<p style="text-align: center;"><strong><a href="https://bartonchronicle.com/obituaries-june-28-2017/obit-norris/" rel="attachment wp-att-30850"><img class="alignleft size-medium wp-image-30850" src="https://bartonchronicle.com/wp-content/uploads/obit-Norris-226x300.jpg" alt="" width="226" height="300" srcset="https://bartonchronicle.com/wp-content/uploads/obit-Norris-226x300.jpg 226w, https://bartonchronicle.com/wp-content/uploads/obit-Norris-415x550.jpg 415w, https://bartonchronicle.com/wp-content/uploads/obit-Norris.jpg 713w" sizes="(max-width: 226px) 100vw, 226px" /></a>Linda Colleen Norris</strong></p>
<p>Linda Colleen Norris, 70, died at the Northeast Vermont Regional Hospital in St. Johnsbury, on June 20, 2017, after a short illness.</p>
<p>She was born April 7, 1947, in Newport Center, the youngest daughter of Harold G. Norris and Doris (Bean) Norris.</p>
<p>She was a very cheerful, happy person who liked to help her family any time in any way. She will be buried beside her parents in the Newport Center Cemetery.</p>
<p>She is survived by her siblings: Kathryn Macie and Barbara Kimball, both of Coventry, Ferol Curtis and her husband, Donald, of Gilford, New Hampshire, and Brian Norris and his wife, Colette, of Newport Center; and by many nieces and nephews. She was predeceased by her brothers-in-law: Arland Macie and Raymond Kimball.</p>
<p>Funeral services will be held at 2 p.m., on Saturday, July 1, at the Curtis-Britch-Converse-Rushford Funeral Home, 4670 Darling Hill Road, Newport, with the Reverend Chris Barton officiating. Friends may call from 1 p.m. until the hour of the service at the funeral home on Saturday.</p>
<p>Online condolences may be shared at curtis-britch.com.</p>
<div class="addtoany_share_save_container addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://bartonchronicle.com/obituaries-june-28-2017/" data-a2a-title="Obituaries June 28, 2017"><a href="https://www.addtoany.com/share" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.addtoany.com/share', '');" class="a2a_dd addtoany_share_save"><img src="https://bartonchronicle.com/wp-content/plugins/add-to-any/share_save_171_16.png" width="171" height="16" alt="Share"/></a></div></div>			</div><!-- .entry-content -->

	<footer class="entry-meta">
		This entry was posted in <a href="https://bartonchronicle.com/category/obituaries/" rel="category tag">Obituaries</a> and tagged <a href="https://bartonchronicle.com/tag/curtis-britch/" rel="tag">curtis-britch</a>, <a href="https://bartonchronicle.com/tag/death/" rel="tag">death</a>, <a href="https://bartonchronicle.com/tag/funeral/" rel="tag">funeral</a>, <a href="https://bartonchronicle.com/tag/linda-colleen-norris/" rel="tag">Linda Colleen Norris</a>, <a href="https://bartonchronicle.com/tag/obits/" rel="tag">obits</a>, <a href="https://bartonchronicle.com/tag/obituaries-2/" rel="tag">obituaries</a>, <a href="https://bartonchronicle.com/tag/peter-fagan/" rel="tag">Peter Fagan</a>, <a href="https://bartonchronicle.com/tag/sidney-ames-huguenin-jr/" rel="tag">Sidney Ames Huguenin Jr.</a>. Bookmark the <a href="https://bartonchronicle.com/obituaries-june-28-2017/" title="Permalink to Obituaries June 28, 2017" rel="bookmark">permalink</a>.		
			</footer><!-- .entry-meta -->
</article><!-- #post-30847 -->

						<div id="comments">
	
	
			<p class="nocomments">Comments are closed.</p>
	
	
</div><!-- #comments -->

				
			</div><!-- #content -->
		</div><!-- #primary -->
		<div id="secondary" class="widget-area" role="complementary">
			<aside id="sam_pro_place_widget-4" class="widget sam_pro_place_widget"><div id='c9216_56_2' class='sam-pro-container sam-pro-place'><a id='img-56-9216' class='sam-pro-ad' href='http://GO.UBLOCAL.COM/Commercial/' target='_blank'><img src='https://bartonchronicle.com/wp-content/uploads/unionbank-march2017.jpg' ></a></div></aside><aside id="categories-2" class="widget widget_categories"><h3 class="widget-title">Categories</h3>		<ul>
	<li class="cat-item cat-item-5"><a href="https://bartonchronicle.com/category/editors-picks/" >Editor&#039;s Picks</a>
</li>
	<li class="cat-item cat-item-543"><a href="https://bartonchronicle.com/category/editorials-and-opinions/" >Editorials and opinions</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://bartonchronicle.com/category/featuring/" >Featuring</a>
</li>
	<li class="cat-item cat-item-10"><a href="https://bartonchronicle.com/category/obituaries/" >Obituaries</a>
</li>
	<li class="cat-item cat-item-8"><a href="https://bartonchronicle.com/category/reviews/" >Reviews</a>
</li>
	<li class="cat-item cat-item-196"><a href="https://bartonchronicle.com/category/safe-choices/" >Safe Choices Program</a>
</li>
	<li class="cat-item cat-item-678"><a href="https://bartonchronicle.com/category/sports-news/" >Sports</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://bartonchronicle.com/category/uncategorized/" >Uncategorized</a>
</li>
		</ul>
</aside><aside id="text-2" class="widget widget_text">			<div class="textwidget"><!-- (c) 2005, 2012. Authorize.Net is a registered trademark of CyberSource Corporation --> <div class="AuthorizeNetSeal"> <script type="text/javascript" language="javascript">var ANS_customer_id="6d8405e0-4ad7-471a-8e04-10a2ba2c4706";</script> <script type="text/javascript" language="javascript" src="https://verify.authorize.net/anetseal/seal.js" ></script> <a href="http://www.authorize.net/" id="AuthorizeNetText" target="_blank">Credit Card Services</a> </div> </div>
		</aside><aside id="tag_cloud-3" class="widget widget_tag_cloud"><h3 class="widget-title">Tags</h3><div class="tagcloud"><a href="https://bartonchronicle.com/tag/albany/" class="tag-cloud-link tag-link-184 tag-link-position-1" style="font-size: 8.8pt;" aria-label="Albany (20 items)">Albany</a>
<a href="https://bartonchronicle.com/tag/ariel-quiros/" class="tag-cloud-link tag-link-523 tag-link-position-2" style="font-size: 8.5333333333333pt;" aria-label="Ariel Quiros (19 items)">Ariel Quiros</a>
<a href="https://bartonchronicle.com/tag/barton/" class="tag-cloud-link tag-link-254 tag-link-position-3" style="font-size: 14pt;" aria-label="Barton (50 items)">Barton</a>
<a href="https://bartonchronicle.com/tag/bethany-m-dunbar/" class="tag-cloud-link tag-link-62 tag-link-position-4" style="font-size: 12pt;" aria-label="Bethany M. Dunbar (35 items)">Bethany M. Dunbar</a>
<a href="https://bartonchronicle.com/tag/bill-stenger/" class="tag-cloud-link tag-link-93 tag-link-position-5" style="font-size: 10.533333333333pt;" aria-label="Bill Stenger (27 items)">Bill Stenger</a>
<a href="https://bartonchronicle.com/tag/book-reviews/" class="tag-cloud-link tag-link-135 tag-link-position-6" style="font-size: 13.066666666667pt;" aria-label="book reviews (43 items)">book reviews</a>
<a href="https://bartonchronicle.com/tag/books/" class="tag-cloud-link tag-link-136 tag-link-position-7" style="font-size: 13.733333333333pt;" aria-label="books (48 items)">books</a>
<a href="https://bartonchronicle.com/tag/business/" class="tag-cloud-link tag-link-1404 tag-link-position-8" style="font-size: 10.533333333333pt;" aria-label="business (27 items)">business</a>
<a href="https://bartonchronicle.com/tag/chris-braithwaite/" class="tag-cloud-link tag-link-139 tag-link-position-9" style="font-size: 11.6pt;" aria-label="Chris Braithwaite (33 items)">Chris Braithwaite</a>
<a href="https://bartonchronicle.com/tag/coventry/" class="tag-cloud-link tag-link-4007 tag-link-position-10" style="font-size: 10.666666666667pt;" aria-label="Coventry (28 items)">Coventry</a>
<a href="https://bartonchronicle.com/tag/craftsbury/" class="tag-cloud-link tag-link-182 tag-link-position-11" style="font-size: 8.2666666666667pt;" aria-label="Craftsbury (18 items)">Craftsbury</a>
<a href="https://bartonchronicle.com/tag/crime/" class="tag-cloud-link tag-link-195 tag-link-position-12" style="font-size: 11.6pt;" aria-label="crime (33 items)">crime</a>
<a href="https://bartonchronicle.com/tag/curtis-britch/" class="tag-cloud-link tag-link-5474 tag-link-position-13" style="font-size: 13.2pt;" aria-label="curtis-britch (44 items)">curtis-britch</a>
<a href="https://bartonchronicle.com/tag/david-dudley/" class="tag-cloud-link tag-link-2829 tag-link-position-14" style="font-size: 12.666666666667pt;" aria-label="David Dudley (40 items)">David Dudley</a>
<a href="https://bartonchronicle.com/tag/death/" class="tag-cloud-link tag-link-1429 tag-link-position-15" style="font-size: 12.266666666667pt;" aria-label="death (37 items)">death</a>
<a href="https://bartonchronicle.com/tag/derby/" class="tag-cloud-link tag-link-549 tag-link-position-16" style="font-size: 9.0666666666667pt;" aria-label="derby (21 items)">derby</a>
<a href="https://bartonchronicle.com/tag/eb-5/" class="tag-cloud-link tag-link-2890 tag-link-position-17" style="font-size: 8.5333333333333pt;" aria-label="EB-5 (19 items)">EB-5</a>
<a href="https://bartonchronicle.com/tag/economy/" class="tag-cloud-link tag-link-1627 tag-link-position-18" style="font-size: 8.5333333333333pt;" aria-label="economy (19 items)">economy</a>
<a href="https://bartonchronicle.com/tag/education-2/" class="tag-cloud-link tag-link-267 tag-link-position-19" style="font-size: 8pt;" aria-label="education (17 items)">education</a>
<a href="https://bartonchronicle.com/tag/elizabeth-trail/" class="tag-cloud-link tag-link-4211 tag-link-position-20" style="font-size: 18.4pt;" aria-label="Elizabeth Trail (108 items)">Elizabeth Trail</a>
<a href="https://bartonchronicle.com/tag/energy/" class="tag-cloud-link tag-link-22 tag-link-position-21" style="font-size: 8.2666666666667pt;" aria-label="energy (18 items)">energy</a>
<a href="https://bartonchronicle.com/tag/events/" class="tag-cloud-link tag-link-161 tag-link-position-22" style="font-size: 8.5333333333333pt;" aria-label="events (19 items)">events</a>
<a href="https://bartonchronicle.com/tag/food/" class="tag-cloud-link tag-link-64 tag-link-position-23" style="font-size: 8.8pt;" aria-label="Food (20 items)">Food</a>
<a href="https://bartonchronicle.com/tag/funeral/" class="tag-cloud-link tag-link-5499 tag-link-position-24" style="font-size: 12.666666666667pt;" aria-label="funeral (40 items)">funeral</a>
<a href="https://bartonchronicle.com/tag/genealogy-vermont/" class="tag-cloud-link tag-link-512 tag-link-position-25" style="font-size: 8.8pt;" aria-label="genealogy Vermont (20 items)">genealogy Vermont</a>
<a href="https://bartonchronicle.com/tag/glover/" class="tag-cloud-link tag-link-154 tag-link-position-26" style="font-size: 11.6pt;" aria-label="Glover (33 items)">Glover</a>
<a href="https://bartonchronicle.com/tag/jay-peak/" class="tag-cloud-link tag-link-522 tag-link-position-27" style="font-size: 11.333333333333pt;" aria-label="Jay Peak (31 items)">Jay Peak</a>
<a href="https://bartonchronicle.com/tag/john-rodgers/" class="tag-cloud-link tag-link-170 tag-link-position-28" style="font-size: 8pt;" aria-label="John Rodgers (17 items)">John Rodgers</a>
<a href="https://bartonchronicle.com/tag/joseph-gresser/" class="tag-cloud-link tag-link-13 tag-link-position-29" style="font-size: 22pt;" aria-label="Joseph Gresser (205 items)">Joseph Gresser</a>
<a href="https://bartonchronicle.com/tag/lake-region-union-high-school/" class="tag-cloud-link tag-link-183 tag-link-position-30" style="font-size: 12.666666666667pt;" aria-label="Lake Region Union High School (40 items)">Lake Region Union High School</a>
<a href="https://bartonchronicle.com/tag/natalie-hormilla/" class="tag-cloud-link tag-link-204 tag-link-position-31" style="font-size: 10.266666666667pt;" aria-label="Natalie Hormilla (26 items)">Natalie Hormilla</a>
<a href="https://bartonchronicle.com/tag/nathalie-gagnon-joseph/" class="tag-cloud-link tag-link-3887 tag-link-position-32" style="font-size: 13.866666666667pt;" aria-label="Nathalie Gagnon-Joseph (49 items)">Nathalie Gagnon-Joseph</a>
<a href="https://bartonchronicle.com/tag/newport/" class="tag-cloud-link tag-link-238 tag-link-position-33" style="font-size: 16.8pt;" aria-label="Newport (82 items)">Newport</a>
<a href="https://bartonchronicle.com/tag/north-country-union-high-school/" class="tag-cloud-link tag-link-190 tag-link-position-34" style="font-size: 13.066666666667pt;" aria-label="North Country Union High School (43 items)">North Country Union High School</a>
<a href="https://bartonchronicle.com/tag/obits/" class="tag-cloud-link tag-link-5513 tag-link-position-35" style="font-size: 12.133333333333pt;" aria-label="obits (36 items)">obits</a>
<a href="https://bartonchronicle.com/tag/obituaries-2/" class="tag-cloud-link tag-link-1177 tag-link-position-36" style="font-size: 12.933333333333pt;" aria-label="obituaries (42 items)">obituaries</a>
<a href="https://bartonchronicle.com/tag/paul-lefebvre/" class="tag-cloud-link tag-link-46 tag-link-position-37" style="font-size: 13.866666666667pt;" aria-label="Paul Lefebvre (49 items)">Paul Lefebvre</a>
<a href="https://bartonchronicle.com/tag/reviews-2/" class="tag-cloud-link tag-link-316 tag-link-position-38" style="font-size: 12.666666666667pt;" aria-label="reviews (40 items)">reviews</a>
<a href="https://bartonchronicle.com/tag/richard-creaser/" class="tag-cloud-link tag-link-264 tag-link-position-39" style="font-size: 12pt;" aria-label="Richard Creaser (35 items)">Richard Creaser</a>
<a href="https://bartonchronicle.com/tag/sports/" class="tag-cloud-link tag-link-665 tag-link-position-40" style="font-size: 15.733333333333pt;" aria-label="sports (68 items)">sports</a>
<a href="https://bartonchronicle.com/tag/tena-starr/" class="tag-cloud-link tag-link-151 tag-link-position-41" style="font-size: 18.8pt;" aria-label="Tena Starr (117 items)">Tena Starr</a>
<a href="https://bartonchronicle.com/tag/the-chronicle/" class="tag-cloud-link tag-link-367 tag-link-position-42" style="font-size: 9.8666666666667pt;" aria-label="the Chronicle (24 items)">the Chronicle</a>
<a href="https://bartonchronicle.com/tag/vermont-genealogy/" class="tag-cloud-link tag-link-1512 tag-link-position-43" style="font-size: 18.533333333333pt;" aria-label="Vermont genealogy (111 items)">Vermont genealogy</a>
<a href="https://bartonchronicle.com/tag/vermont-obituaries/" class="tag-cloud-link tag-link-461 tag-link-position-44" style="font-size: 19.733333333333pt;" aria-label="Vermont obituaries (138 items)">Vermont obituaries</a>
<a href="https://bartonchronicle.com/tag/wind/" class="tag-cloud-link tag-link-142 tag-link-position-45" style="font-size: 10.533333333333pt;" aria-label="wind (27 items)">wind</a></div>
</aside>		</div><!-- #secondary .widget-area -->

	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">

			
<div id="supplementary" class="two">
	

	

		<div id="third" class="widget-area" role="complementary">
		<aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-bottom-container"><ul id="menu-bottom" class="menu"><li id="menu-item-124" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124"><a href="https://bartonchronicle.com/return-policy/">Return Policy</a></li>
<li id="menu-item-125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125"><a href="https://bartonchronicle.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-16592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16592"><a href="https://bartonchronicle.com/ad-rates/">Ad Rates</a></li>
<li id="menu-item-16593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16593"><a href="https://bartonchronicle.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16594"><a href="https://bartonchronicle.com/print-subscriptions/">Print Subscriptions</a></li>
</ul></div></aside>	</div><!-- #third .widget-area -->
	</div><!-- #supplementary -->
			&copy; 2014 the Chronicle. All Rights Reserved.
	</footer><!-- #colophon -->
</div><!-- #page --><p><em>"Partial funding for development of this website made possible by a Rural Business Enterprise Grant through the Northern Community Investment Corporation from USDA Rural Development."</em></p>

<script type='text/javascript'>/* <![CDATA[ */ var portfolioSlideshowOptions = {  psHash:false, psLoader:false, psFluid:true };/* ]]> */</script><script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/rp-news-ticker/liScroll.min.js?ver=0.7'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/portfolio-slideshow/js/jquery.cycle.all.min.js?ver=2.99'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/portfolio-slideshow/js/portfolio-slideshow.min.js?ver=1.5.1'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/comment-reply.min.js?ver=ff141972d2289c236313b80ee3b30347'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/wp-embed.min.js?ver=ff141972d2289c236313b80ee3b30347'></script>
<a href="http://nekinfo.com" target="_blank">web development: nekinfo.com</a>
</body>
</html>