<!DOCTYPE html>
<html lang="en-US" class="">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://bartonchronicle.com/xmlrpc.php">

<meta property="og:title" content="West Glover solar array completed"><meta property="og:description" content="&nbsp; &nbsp; The town of Glover and the Glover Energy Committee are pleased to announce that the solar array in West Glover is up and generating. It will provide 90 percent of the electricity used by town buildings, streetlights, and sewer pump stations.  Negotiations began in March 2021 with Norwich Solar Technologies of White River Junction. Construction began in September 2022 with West Glover Roaring Brook Solar, LLC, as the owner. The project was officially “commissioned,” i.e., connected to the [&hellip;]"><meta property="og:image" content="https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-1280x800.jpg"><meta name="twitter:card" content="summary_large_image"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Ads on this site are served by WP PRO Advertising System - All In One Ad Manager v5.3.1 - wordpress-advertising.tunasite.com -->
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','wppas_ga');wppas_ga('create', 'UA-113865155-1', 'auto');</script><!-- / WP PRO Advertising System - All In One Ad Manager. -->


	<!-- This site is optimized with the Yoast SEO plugin v19.10 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>West Glover solar array completed - Barton Chronicle Newspaper</title>
	<link rel="canonical" href="https://bartonchronicle.com/west-glover-solar-array-completed/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="West Glover solar array completed - Barton Chronicle Newspaper" />
	<meta property="og:description" content="&nbsp; &nbsp; The town of Glover and the Glover Energy Committee are pleased to announce that the solar array in West Glover is up and generating. It will provide 90 percent of the electricity used by town buildings, streetlights, and sewer pump stations.  Negotiations began in March 2021 with Norwich Solar Technologies of White River Junction. Construction began in September 2022 with West Glover Roaring Brook Solar, LLC, as the owner. The project was officially “commissioned,” i.e., connected to the [&hellip;]" />
	<meta property="og:url" content="https://bartonchronicle.com/west-glover-solar-array-completed/" />
	<meta property="og:site_name" content="Barton Chronicle Newspaper" />
	<meta property="article:published_time" content="2022-12-14T14:04:49+00:00" />
	<meta property="og:image" content="https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg" />
	<meta property="og:image:width" content="2400" />
	<meta property="og:image:height" content="1332" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Tracy Davis Pierce" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://bartonchronicle.com/west-glover-solar-array-completed/","url":"https://bartonchronicle.com/west-glover-solar-array-completed/","name":"West Glover solar array completed - Barton Chronicle Newspaper","isPartOf":{"@id":"https://bartonchronicle.com/#website"},"primaryImageOfPage":{"@id":"https://bartonchronicle.com/west-glover-solar-array-completed/#primaryimage"},"image":{"@id":"https://bartonchronicle.com/west-glover-solar-array-completed/#primaryimage"},"thumbnailUrl":"https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg","datePublished":"2022-12-14T14:04:49+00:00","dateModified":"2022-12-14T14:04:49+00:00","author":{"@id":"https://bartonchronicle.com/#/schema/person/009c6da2311879ba9e6c4558dda3a572"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://bartonchronicle.com/west-glover-solar-array-completed/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://bartonchronicle.com/west-glover-solar-array-completed/#primaryimage","url":"https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg","contentUrl":"https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg","width":2400,"height":1332,"caption":"Matt Smith of Brite Lite Electric throws the switch to connect the new West Glover solar array to the grid as Jack Sumberg, Sara Gluckman, and Mariel Hess of the Glover Energy Committee look on. Photo courtesy of Ann Creaven"},{"@type":"WebSite","@id":"https://bartonchronicle.com/#website","url":"https://bartonchronicle.com/","name":"Barton Chronicle Newspaper","description":"Log in to read current news &amp; events","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://bartonchronicle.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://bartonchronicle.com/#/schema/person/009c6da2311879ba9e6c4558dda3a572","name":"Tracy Davis Pierce","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://bartonchronicle.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/9f728f599f018573db839dba84793b15?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/9f728f599f018573db839dba84793b15?s=96&d=mm&r=g","caption":"Tracy Davis Pierce"},"url":"https://bartonchronicle.com/author/tracy-davis-pierce/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//static.addtoany.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Barton Chronicle Newspaper &raquo; Feed" href="https://bartonchronicle.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Barton Chronicle Newspaper &raquo; Comments Feed" href="https://bartonchronicle.com/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.11.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script
				src="//www.googletagmanager.com/gtag/js?id=UA-113865155-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/bartonchronicle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='WPPAS_VBC_BNR_STYLE-css' href='https://bartonchronicle.com/wp-content/plugins/wppas/public/assets/css/vbc/wppas_vbc_bnr.css?ver=5.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://bartonchronicle.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://bartonchronicle.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='times-style-css' href='https://bartonchronicle.com/wp-content/themes/times/styles.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://bartonchronicle.com/wp-content/themes/times-child/styles.css?ver=1.6' type='text/css' media='all' />
<link rel='stylesheet' id='times-fonts-css' href='https://fonts.googleapis.com/css?family=PT+Serif%3A400%2C700%2C700italic%7CDomine%3A400%2C700%7CWork+Sans%3A300%2C400%2C500%2C600%2C700%2C900&#038;subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Cvietnamese&#038;ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://bartonchronicle.com/wp-content/themes/times/inc/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css' href='https://bartonchronicle.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.16' type='text/css' media='all' />
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/clipboard.min.js?ver=2.0.11' id='clipboard-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/plupload/moxie.min.js?ver=1.3.5' id='moxiejs-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/plupload/plupload.min.js?ver=2.1.9' id='plupload-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/underscore.min.js?ver=1.13.4' id='underscore-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/dist/dom-ready.min.js?ver=392bdd43726760d1f3ca' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/dist/hooks.min.js?ver=4169d3cf8e8d95a3d6d5' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/dist/i18n.min.js?ver=9e794f35a71bb98672ae' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/dist/a11y.min.js?ver=ecce20f002eda4c19664' id='wp-a11y-js'></script>
<script type='text/javascript' id='plupload-handlers-js-extra'>
/* <![CDATA[ */
var pluploadL10n = {"queue_limit_exceeded":"You have attempted to queue too many files.","file_exceeds_size_limit":"%s exceeds the maximum upload size for this site.","zero_byte_file":"This file is empty. Please try another.","invalid_filetype":"Sorry, you are not allowed to upload this file type.","not_an_image":"This file is not an image. Please try another.","image_memory_exceeded":"Memory exceeded. Please try another smaller file.","image_dimensions_exceeded":"This is larger than the maximum size. Please try another.","default_error":"An error occurred in the upload. Please try again later.","missing_upload_url":"There was a configuration error. Please contact the server administrator.","upload_limit_exceeded":"You may only upload 1 file.","http_error":"Unexpected response from the server. The file may have been uploaded successfully. Check in the Media Library or reload the page.","http_error_image":"The server cannot process the image. This can happen if the server is busy or does not have enough resources to complete the task. Uploading a smaller image may help. Suggested maximum size is 2560 pixels.","upload_failed":"Upload failed.","big_upload_failed":"Please try uploading this file with the %1$sbrowser uploader%2$s.","big_upload_queued":"%s exceeds the maximum upload size for the multi-file uploader when used in your browser.","io_error":"IO error.","security_error":"Security error.","file_cancelled":"File canceled.","upload_stopped":"Upload stopped.","dismiss":"Dismiss","crunching":"Crunching\u2026","deleted":"moved to the Trash.","error_uploading":"\u201c%s\u201d has failed to upload.","unsupported_image":"This image cannot be displayed in a web browser. For best results convert it to JPEG before uploading.","noneditable_image":"This image cannot be processed by the web server. Convert it to JPEG or PNG before uploading.","file_url_copied":"The file URL has been copied to your clipboard"};
/* ]]> */
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/plupload/handlers.min.js?ver=6.1.1' id='plupload-handlers-js'></script>
<script type='text/javascript' id='wppas_vbc_upload-js-extra'>
/* <![CDATA[ */
var wppas_vbc_upload = {"ajaxurl":"https:\/\/bartonchronicle.com\/wp-admin\/admin-ajax.php","nonce":"4c8d1b335a","remove":"737a8c89fe","number":"1","upload_enabled":"1","confirmMsg":"Are you sure you want to delete this?","plupload":{"runtimes":"html5,flash,html4","browse_button":"wppas-vbc-uploader","container":"wppas-vbc-upload-container","file_data_name":"wppas_vbc_upload_file","max_file_size":"100000000b","url":"https:\/\/bartonchronicle.com\/wp-admin\/admin-ajax.php?action=wppas_vbc_upload&nonce=726e3edfa5","flash_swf_url":"https:\/\/bartonchronicle.com\/wp-includes\/js\/plupload\/plupload.flash.swf","filters":[{"title":"Allowed Files","extensions":"jpg,gif,png"}],"multipart":true,"urlstream_upload":true,"multipart_params":{"upload_folder":""}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wppas/public/assets/js/vbc/AjaxUpload.js?ver=6.1.1' id='wppas_vbc_upload-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/google-analytics-premium/assets/js/frontend-gtag.min.js?ver=8.11.0' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/bartonchronicle.com","hash_tracking":"false","ua":"UA-113865155-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' id='addtoany-core-js-before'>
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
</script>
<script type='text/javascript' async src='https://static.addtoany.com/menu/page.js' id='addtoany-core-js'></script>
<script type='text/javascript' async src='https://bartonchronicle.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-jquery-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wppas/templates/js/advertising.js?ver=6.1.1' id='wppas_dummy_advertising-js'></script>
<link rel="https://api.w.org/" href="https://bartonchronicle.com/wp-json/" /><link rel="alternate" type="application/json" href="https://bartonchronicle.com/wp-json/wp/v2/posts/41967" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bartonchronicle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bartonchronicle.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://bartonchronicle.com/?p=41967' />
<link rel="alternate" type="application/json+oembed" href="https://bartonchronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://bartonchronicle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&#038;format=xml" />
<link rel="icon" href="https://bartonchronicle.com/wp-content/uploads/cropped-C-png-32x32.png" sizes="32x32" />
<link rel="icon" href="https://bartonchronicle.com/wp-content/uploads/cropped-C-png-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://bartonchronicle.com/wp-content/uploads/cropped-C-png-180x180.png" />
<meta name="msapplication-TileImage" content="https://bartonchronicle.com/wp-content/uploads/cropped-C-png-270x270.png" />
<script type="text/javascript">function timesWO(o,n,e,t){var r=screen.width/2-e/2,i=screen.height/2-t/2;return window.open(o,n,"toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width="+e+", height="+t+", top="+i+", left="+r)}var timesStickySidebar=true;var timesSpecialLayout=true;var timesHeroParallax=true;var timesElevateClick=true;var timesLoadFade=true;var timesLoadFadeIn=false;var isSafariFade=/^((?!chrome|android).)*safari/i.test(navigator.userAgent);var timesScrollTo=true;var timesTransparentLabels=true;var timesAutoHyphenate="headlines_body";var timesHyphenateBranding=false;var timesExptTweak=true;var timesFeaturedParagraph=true;var timesAutoDropCap=true;var timesHeaderLayout='basic';var timesMenuLayout='basic';var timesMobileMenuLayout='compact-mobile';var timesIsCustomizer=false;var timesIsTicker=false;var timesHomepagePostIDs=[];var timesIgnoreMailtoLinks=false;var timesHomepageUnique=false;var timesHomepageUsedPostsJSON=[];var timesSingularPostID=41967;var timesSingularBaseURL='/west-glover-solar-array-completed/';var timesPostDisableFeaturedParagraph=false;var timesPostDisableAutoDropCap=false;var timesPostCommentPageNumber=1;var timesPostCommentDefaultSorting='oldest';</script></head>

<body data-rsssl=1 class="post-template-default single single-post postid-41967 single-format-standard standard-article-layout">
<script type="text/javascript">(function($){"use strict";function fadeInPage(){function d(){setTimeout(function(){$("body").addClass("loaded")},8e3)}d(),1==isSafariFade&&$("body").addClass("zero loaded"),1==isSafariFade&&0==timesLoadFade&&$("body").ready(function(){$("body").addClass("zero loaded")}),1==timesLoadFadeIn&&$(window).bind("load",function(){$("body").addClass("loaded")}),$(window).bind("beforeunload",function(){1!=isSafariFade&&0!=timesLoadFade&&(timesIgnoreMailtoLinks?timesIgnoreMailtoLinks=!1:($("body").removeClass("zero loaded"),setTimeout(function(){$("body").addClass("loaded")},6e3))),d()})}$("html").addClass("js"),"opacity"in document.documentElement.style&&$("html").addClass("js-opacity"),"onmouseover"in document.documentElement&&$("html").addClass("hoverable"),fadeInPage();})(jQuery);if ( isSafariFade || timesLoadFade && !timesLoadFadeIn || !timesLoadFadeIn ) document.body.classList.add("zero", "loaded");</script><a class="skip-link screen-reader-text before-header-link" href="#content">Skip to content</a>

	<nav id="sec-navigation" class="layout-shadow padding-small">
		<div class="row">
			<div class="search-icon"><img src="https://bartonchronicle.com/wp-content/themes/times/img/magni.svg" class="svg-inject"><span class="screen-reader-text">Search</span></div>
						<div class="date" title="Date &amp; Time in UTC -4 Time Zone"><time datetime="2022-12-16">December 15th, 2022</time></div>
			
			<div class="menu-bottom-container"><ul id="secondary-menu" class="menu"><li id="menu-item-124" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124"><a href="https://bartonchronicle.com/return-policy/">Return Policy</a></li>
<li id="menu-item-125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125"><a href="https://bartonchronicle.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-16592" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16592"><a href="https://bartonchronicle.com/ad-rates/">Ad Rates</a></li>
<li id="menu-item-16593" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16593"><a href="https://bartonchronicle.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16594"><a href="https://bartonchronicle.com/print-subscriptions/">Print Subscriptions</a></li>
</ul></div>
						<div class="social-media-icons">
				<a class="facebook" href="https://www.facebook.com/bartonvtchronicle/" target="_blank"></a> <a class="instagram" href="https://www.instagram.com/thebartonchronicle" target="_blank"></a> 			</div>
					</div>
	</nav>


<div class="row">
	<header id="masthead" class="site-header basic hide-tagline" role="banner">
		
		<div class="site-branding no-hy times-logo">
			<a href="https://bartonchronicle.com/" rel="home"><img width="" height="" src="https://bartonchronicle.com/wp-content/uploads/Chronicle-headline.png" alt="Barton Chronicle Newspaper - Log in to read current news &amp; events"></a>	</div>
		
			<nav id="site-navigation" class="main-navigation custom-menu" role="navigation">
	<ul id="primary-menu" class="clear"><li><a href="https://vtchronicle.wpengine.com/">Home</a></li><li class="times-menu-item-fade top-level-cat" data-times-cmcid="10"><a href="https://bartonchronicle.com/category/obituaries/">Obituaries</a><section class="top-level-post-area std-dropdown"><header class="top-section-info clear"><h1>Obituaries</h1><p class="cat-description"> </p><a href="https://bartonchronicle.com/category/obituaries/" class="more-btn">More Articles</a><p class="cat-post-count">667 articles</p></header><div class="controls"><div class="left"><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-med-left.svg" class="svg-inject"></div><div class="right"><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-med-right.svg" class="svg-inject"></div></div><div class="cat-posts clear"><div class="placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div><div class="posts-wrap"></div></div></section></li><li><a href="https://bartonchronicle.com/property-transfers/">Property Transfers</a></li><li class="times-menu-item-fade"><a href="https://bartonchronicle.com/ad-rates/">Advertise</a><div class="std-dropdown depth-1"><ul class="sub-menu-items child-cats"><li><a href="https://bartonchronicle.com/submit-classifieds/">Submit Classifieds</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li><li><a href="https://bartonchronicle.com/submit-print-ad/">Submit Print Ad</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li></ul><section class="post-cat-area"><div class="post-cat-wrap placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div></section></div></li><li><a href="https://bartonchronicle.com/classifieds/">Classifieds</a></li><li><a href="https://bartonchronicle.com/chronicle-online-edition/">Online Edition</a></li><li><a href="https://bartonchronicle.com/kingdom-calendar-of-weekly-events/">Kingdom Calendar of Weekly Events</a></li><li class="times-menu-item-fade"><a href="#">Subscribe</a><div class="std-dropdown depth-1"><ul class="sub-menu-items child-cats"><li><a href="https://bartonchronicle.com/print-subscriptions/">Print Subscription</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li><li><a href="https://vtchronicle.wpengine.com/create-online-subscription">Create Annual  Online Subscription</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li><li><a href="https://bartonchronicle.com/create-short-term-online-subscription/">Create Short Term Online Subscription</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li></ul><section class="post-cat-area"><div class="post-cat-wrap placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div></section></div></li><li class="times-menu-item-fade"><a href="https://bartonchronicle.com/contact-us/">Contact Us</a><div class="std-dropdown depth-1"><ul class="sub-menu-items child-cats"><li><a href="#">What&#8217;s New?</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"><div class="std-dropdown depth-2"><ul class="sub-menu-items child-cats"><li data-times-cmcid="6207"><a href="https://bartonchronicle.com/category/police-crime/">Crime &#038; Police Reports</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li><li data-times-cmcid="6208"><a href="https://bartonchronicle.com/category/politics/">Politics</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li><li data-times-cmcid="6229"><a href="https://bartonchronicle.com/category/state-news/">State News</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li></ul><section class="post-cat-area"><div class="post-cat-wrap placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div></section></div></li><li><a href="https://bartonchronicle.com/chronicle-staff-bios/">Chronicle staff bios</a><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-right.svg" class="svg-inject"></li></ul><section class="post-cat-area"><div class="post-cat-wrap placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div></section></div></li><li class="times-menu-item-fade top-level-cat" data-times-cmcid="8"><a href="https://bartonchronicle.com/category/reviews/">Reviews</a><section class="top-level-post-area std-dropdown"><header class="top-section-info clear"><h1>Reviews</h1><p class="cat-description"> </p><a href="https://bartonchronicle.com/category/reviews/" class="more-btn">More Articles</a><p class="cat-post-count">83 articles</p></header><div class="controls"><div class="left"><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-med-left.svg" class="svg-inject"></div><div class="right"><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-med-right.svg" class="svg-inject"></div></div><div class="cat-posts clear"><div class="placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div><div class="posts-wrap"></div></div></section></li><li class="times-menu-item-fade top-level-cat" data-times-cmcid="6"><a href="https://bartonchronicle.com/category/featuring/">Featuring</a><section class="top-level-post-area std-dropdown"><header class="top-section-info clear"><h1>Featuring</h1><p class="cat-description"> </p><a href="https://bartonchronicle.com/category/featuring/" class="more-btn">More Articles</a><p class="cat-post-count">167 articles</p></header><div class="controls"><div class="left"><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-med-left.svg" class="svg-inject"></div><div class="right"><img src="https://bartonchronicle.com/wp-content/themes/times/img/arrow-med-right.svg" class="svg-inject"></div></div><div class="cat-posts clear"><div class="placeholder"><div class="holder"></div><div class="holder"></div><div class="holder"></div><div class="holder"></div></div><div class="posts-wrap"></div></div></section></li></ul>	<div class="compact-menu row">
		<div class="wrap">
			<span class="compact-menu-btn"><img src="https://bartonchronicle.com/wp-content/themes/times/img/hamburger.svg" class="svg-inject">Menu</span>
			<span class="title"><a href="https://bartonchronicle.com/" rel="home"><img width="" height="" src="https://bartonchronicle.com/wp-content/uploads/Chronicle-headline-compact.png" alt="Barton Chronicle Newspaper - Log in to read current news &amp; events"></a></span>
			<span class="compact-search-btn"><img src="https://bartonchronicle.com/wp-content/themes/times/img/magni.svg" class="svg-inject"></span>
		</div>
	</div>
</nav>
<div class="search-cover"><div class="row"><form role="search" method="get" class="custom-search-form" action="https://bartonchronicle.com/"><input type="submit" class="search-submit" value="Search"><input type="search" class="search-field" placeholder="What are you looking for?" value="" autocomplete="off" name="s" title="Search for:"><img src="https://bartonchronicle.com/wp-content/themes/times/img/magni-big.svg" class="svg-inject search-icon"></form></div></div>				<div id="navshad"></div>
			</header>

	</div>

	<div class="row" id="content">

		<div class="col lt10">
			<article class="post mass single standard-layout post-41967 type-post status-publish format-standard has-post-thumbnail hentry category-around-the-nek category-this-week" id="post-41967">

				<div class="introduction">
	<div class="category-labels"><div class="label full-text label-cat-id-6272"><span class="label-category-name">Around the Northeast Kingdom</span><a class="label-category-link" href="https://bartonchronicle.com/category/around-the-nek/" rel="category"></a></div></div>	<h1 class="title">West Glover solar array completed</h1>
	<p class="meta"><span class="published-ago"><time datetime="2022-12-14T10:04:49-04:00"><span class="published">Published </span>1 day ago</time><span class="hyphen-single"></span></span><a href="https://bartonchronicle.com/author/tracy-davis-pierce/" rel="author" class="author"> Tracy Davis Pierce</a><span class="short-ago"><span class="hyphen-single"></span><time datetime="2022-12-14T10:04:49-04:00">1d ago</time> </span><span class="bookmarks-count"><img src="https://bartonchronicle.com/wp-content/themes/times/img/bookmark-meta-mobile.svg" class="svg-inject meta-mobile"><img src="https://bartonchronicle.com/wp-content/themes/times/img/bookmark-meta.svg" class="svg-inject meta-normal"><span class="times-screen-reader-only"> &bull; Bookmarks: </span>11</span></p></div>

				<hr>

				<figure class="featured-image"><img class="attachment-single-thumb size-single-thumb wp-post-image" alt width="2400" height="1332" srcset="https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-360x200.jpg 360w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-700x389.jpg 700w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-720x400.jpg 720w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-780x433.jpg 780w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-1120x622.jpg 1120w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-1400x777.jpg 1400w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-1560x866.jpg 1560w, https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo-2240x1243.jpg 2240w" sizes="(min-width:1200px) 780px, (min-width:1200px) and (min-aspect-ratio:2) 1560px, (min-width:600px) 700px, (min-width:600px) and (min-aspect-ratio:2) 1400px, (min-width:360px) 360px, (min-width:360px) and (min-aspect-ratio:2) 720px, 100vw"><figcaption>Matt Smith of Brite Lite Electric throws the switch to connect the new West Glover solar array to the grid as Jack Sumberg, Sara Gluckman, and Mariel Hess of the Glover Energy Committee look on. Photo courtesy of Ann Creaven</figcaption></figure>
				<div class="content bass">
					<p>&nbsp;</p>
<p>&nbsp;</p>
<p>The town of Glover and the Glover Energy Committee are pleased to announce that the solar array in West Glover is up and generating. It will provide 90 percent of the electricity used by town buildings, streetlights, and sewer pump stations.  Negotiations began in March 2021 with Norwich Solar Technologies of White River Junction. Construction began in September 2022 with West Glover Roaring Brook Solar, LLC, as the owner. The project was officially “commissioned,” i.e., connected to the grid, on November 29.</p>
<p>The town of Glover will purchase the electricity generated by the project at a discount of 11.5 percent below the Vermont Electric Co-op rate. During its anticipated 25-year lifetime, this array is expected to produce 2 million kilowatt hours of electricity with an initial anticipated savings for the town of Glover of $1,600 per year and up to $52,000 over the life of the project.</p>
<p>The project is located behind the Glover ambulance bay in West Glover Village, on the site of the retired village leach field, out of use since the village was connected to the Glover Village sewer system in 2009.</p>
<p>The Glover Energy Committee recently received a $4,000 grant, through the Vermont Council on Rural Development Climate Catalysts Innovation Fund grant program, to purchase two e-bikes, which will be loaned out from the Glover library.</p>
<p>Library patrons will be able to borrow the bikes and experience the advantages of an electric assisted bicycle without having to purchase or rent one. The bikes will be available in the spring of 2023. Anyone interested in helping with this project, please contact the Glover energy committee by email at: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e483888b9281969290818a8196839da48389858d88ca878b89ca">[email&#160;protected]</a> — from the Glover Energy Committee.</p>
<p>&nbsp;</p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://bartonchronicle.com/west-glover-solar-array-completed/" data-a2a-title="West Glover solar array completed"><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"><img src="https://static.addtoany.com/buttons/share_save_171_16.png" alt="Share"></a></div></div>									</div>

				<aside class="mobile-post-info mobile-sidebar">
					<section class="post-author-bio"><img alt='' src='https://secure.gravatar.com/avatar/9f728f599f018573db839dba84793b15?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9f728f599f018573db839dba84793b15?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' loading='lazy' decoding='async'/><h3>Tracy Davis Pierce</h3><p> <a href="https://bartonchronicle.com/author/tracy-davis-pierce/" class="more-link">More <span>&raquo;</span></a></p></section>
					<section class="times-post-share-buttons bass-share-buttons"><a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Facebook', '540', '460')">Share</a><a class="twitter" href="https://twitter.com/home?status=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://twitter.com/home?status=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Twitter', '540', '500')">Tweet</a><a class="gplus" href="https://plus.google.com/share?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://plus.google.com/share?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Google+', '512', '500')"><span class="screen-reader-text">Share on Google+</span></a><a class="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&amp;media=https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg&amp;description=WordPress" onclick="event.preventDefault(); timesWO('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&amp;media=https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg&amp;description=WordPress', 'Share this post on Pinterest', '540', '500')"><span class="screen-reader-text">Pin on Pinterest</span></a><a class="whatsapp" href="whatsapp://send?text=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F"><span class="screen-reader-text">Send with WhatsApp</span></a></section>
									</aside>

				<section class="inaction clear"><div class="btn recommend-btn tvote-wrap liked"><a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41967&disabled=true&is_comment=false" class="tvote-button tvote-button-41967 liked" data-nonce="a596fa3a79" data-post-id="41967" data-iscomment="false"></a><span><span class="tvote-count">11</span> recommended</span><img src="https://bartonchronicle.com/wp-content/themes/times/img/big-bookmark.svg" class="svg-inject"></div><div class="btn share-btn"><img src="https://bartonchronicle.com/wp-content/themes/times/img/share-big.svg" alt="comments icon" class="svg-inject share-icon"><span>0 shares</span><div class="tooltip bass-share-buttons"><a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Facebook', '540', '460')">Share</a><a class="twitter" href="https://twitter.com/home?status=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://twitter.com/home?status=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Twitter', '540', '500')">Tweet</a><a class="gplus" href="https://plus.google.com/share?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://plus.google.com/share?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Google+', '512', '500')">Share</a><a class="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&amp;media=https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg&amp;description=WordPress" onclick="event.preventDefault(); timesWO('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&amp;media=https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg&amp;description=WordPress', 'Share this post on Pinterest', '540', '500')">Pin it</a></div></div></section>
			</article>
		</div>

		<div class="col lt5">

			<div class="stats">
									<div class="stat post-views">
						<span class="count">176</span> <span class="text">views</span>					</div>
				
								<div class="bookmark-post tvote-wrap liked" title="Bookmark">
					<a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41967&disabled=true&is_comment=false" class="tvote-button tvote-button-41967 liked" data-nonce="a596fa3a79" data-post-id="41967" data-iscomment="false"></a>					<img src="https://bartonchronicle.com/wp-content/themes/times/img/bookmark-single.svg" alt="bookmark icon" class="svg-inject">
				</div>
				
			</div>

			<aside class="widget-area article-sidebar">

								<section class="widget post-info">
					<h2 class="widget-title bd2">Article info</h2>

					<section class="post-author-bio"><img alt='' src='https://secure.gravatar.com/avatar/9f728f599f018573db839dba84793b15?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9f728f599f018573db839dba84793b15?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' loading='lazy' decoding='async'/><h3>Tracy Davis Pierce</h3><p> <a href="https://bartonchronicle.com/author/tracy-davis-pierce/" class="more-link">More <span>&raquo;</span></a></p></section>
									</section>
				
				
									<section class="widget share-post">
						<h2 class="widget-title bd2">Share this article</h2>
						<section class="times-post-share-buttons bass-share-buttons"><a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Facebook', '540', '460')">Share</a><a class="twitter" href="https://twitter.com/home?status=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://twitter.com/home?status=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Twitter', '540', '500')">Tweet</a><a class="gplus" href="https://plus.google.com/share?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F" onclick="event.preventDefault(); timesWO('https://plus.google.com/share?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F', 'Share this post on Google+', '512', '500')"><span class="screen-reader-text">Share on Google+</span></a><a class="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&amp;media=https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg&amp;description=WordPress" onclick="event.preventDefault(); timesWO('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F&amp;media=https://bartonchronicle.com/wp-content/uploads/2022/12/pr-glover-solar-array-photo.jpg&amp;description=WordPress', 'Share this post on Pinterest', '540', '500')"><span class="screen-reader-text">Pin on Pinterest</span></a><a class="whatsapp" href="whatsapp://send?text=https%3A%2F%2Fbartonchronicle.com%2Fwest-glover-solar-array-completed%2F"><span class="screen-reader-text">Send with WhatsApp</span></a></section>					</section>
				
				<div class="user-widgets user-widgets-article">
					<section id="text-8" class="widget bass widget_text">			<div class="textwidget">
</div>
		</section><section id="custom_html-3" class="widget_text widget bass widget_custom_html"><div class="textwidget custom-html-widget"><div style="text-align:center;">
<img src="https://bartonchronicle.com/wp-content/uploads/chronicle-subscribe.jpg" alt="Subscribe" />
<div class="post" style="margin-bottom:20px;">
<h1><a href="https://vtchronicle.wpengine.com/print-subscriptions/">Print Subscription</a></h1>
<h1><a href="https://vtchronicle.wpengine.com/create-online-subscription/">Online Subscription</a></h1>
</div></div></section><section id="block-24" class="widget bass widget_block"></section>				</div>

			</aside>
		</div>
	</div>

	<div class="section-darker">
	<div class="row">

		<div class="col st8 lt10">
					</div>

		<aside class="col st7 lt5 widget-area singular-comments-sidebar article-comments-sidebar">

						<section class="recommended-posts widget">
				<h2 class="widget-title bd2">You may find interesting...</h2>
				<article class="post vert tweak expt post-id-41877 cover">

			<div class="thumbnail">
			<a href="https://bartonchronicle.com/vermont-couple-are-blown-off-course/">
				<img width="360" height="258" src="https://bartonchronicle.com/wp-content/uploads/2022/11/random-florida-hotel-sea-wall-cmyk-360x258.jpg" class="attachment-times-horiz size-times-horiz wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://bartonchronicle.com/wp-content/uploads/2022/11/random-florida-hotel-sea-wall-cmyk-360x258.jpg 1x, https://bartonchronicle.com/wp-content/uploads/2022/11/random-florida-hotel-sea-wall-cmyk-720x516.jpg 2x" />			</a>
			<div class="tvote-wrap standard"><span class="button"><i></i><i></i><a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41877&disabled=true&is_comment=false" class="tvote-button tvote-button-41877" data-nonce="a596fa3a79" data-post-id="41877" data-iscomment="false"></a></span><span class="context tooltip"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
	
	<div class="caption">
		<h1 class="title"><a href="https://bartonchronicle.com/vermont-couple-are-blown-off-course/" rel="bookmark">Vermont couple are blown off course</a></h1>
		<p class="meta"><time datetime="2022-11-23T09:49:09-04:00">Published 3w ago</time><span class="hyphen">&nbsp;-&nbsp;</span><a href="https://bartonchronicle.com/author/tracy-davis-pierce/" rel="author" class="author">Tracy Davis Pierce</a></p>		<p class="excerpt">&nbsp; &nbsp; by Tena Starr Maybe it&rsquo;s because I grew up on the Missisquoi, which routinely flooded fields on our farm, the road and bridge as well, so we were sometimes stranded with the road under water on both sides.&nbsp; Maybe it was because Dad didn&rsquo;t seem particularly... <a href="https://bartonchronicle.com/vermont-couple-are-blown-off-course/" class="more-link" rel="bookmark">More <span>&raquo;</span></a></p>	</div>
</article><article class="post vert tweak expt post-id-41940 cover">

			<div class="thumbnail">
			<a href="https://bartonchronicle.com/vsp-seek-assistance-in-glover-runaway-juvenile/">
				<img width="360" height="258" src="https://bartonchronicle.com/wp-content/uploads/2022/12/22A5005610-Promise-Pic-360x258.jpg" class="attachment-times-horiz size-times-horiz wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://bartonchronicle.com/wp-content/uploads/2022/12/22A5005610-Promise-Pic-360x258.jpg 1x, https://bartonchronicle.com/wp-content/uploads/2022/12/22A5005610-Promise-Pic-720x516.jpg 2x" />			</a>
			<div class="tvote-wrap standard liked"><span class="button"><i></i><i></i><a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41940&disabled=true&is_comment=false" class="tvote-button tvote-button-41940 liked" data-nonce="a596fa3a79" data-post-id="41940" data-iscomment="false"></a></span><span class="context tooltip"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
	
	<div class="caption">
		<h1 class="title"><a href="https://bartonchronicle.com/vsp-seek-assistance-in-glover-runaway-juvenile/" rel="bookmark">VSP seek assistance in locating Glover runaway juvenile</a></h1>
		<p class="meta"><time datetime="2022-12-09T09:23:13-04:00">Published 6d ago</time><span class="hyphen">&nbsp;-&nbsp;</span><a href="https://bartonchronicle.com/author/tracy-davis-pierce/" rel="author" class="author">Tracy Davis Pierce</a></p>		<p class="excerpt">On 12/8/22 at approximately 7:39 a.m., it was reported to the Vermont State Police that Promise Kempton had run away from her residence on First Pl., in the town of Glover.&nbsp;&nbsp;The Vermont State Police has been actively pursuing leads on Kempton&rsquo;s whereabouts and... <a href="https://bartonchronicle.com/vsp-seek-assistance-in-glover-runaway-juvenile/" class="more-link" rel="bookmark">More <span>&raquo;</span></a></p>	</div>
</article>			</section>
			
						<section class="this-cat-posts widget">
				<h2 class="widget-title bd2"><a href="https://bartonchronicle.com/category/around-the-nek/">From this category &raquo;</a></h2>
				<article class="post horiz-mini expt post-id-41715 cover">
			<div class="thumbnail">
			<a href="https://bartonchronicle.com/kingdom-kind-awarded-triple-crown/" rel="bookmark"><img width="54" height="54" src="https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-54x54.jpg 54w, https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-150x150.jpg 150w, https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-72x72.jpg 72w, https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-144x144.jpg 144w, https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-108x108.jpg 108w, https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-58x58.jpg 58w, https://bartonchronicle.com/wp-content/uploads/2022/11/kingdom-kind-hydro-system-CMYK-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41715&disabled=true&is_comment=false" class="tvote-button tvote-button-41715" data-nonce="a596fa3a79" data-post-id="41715" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://bartonchronicle.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://bartonchronicle.com/kingdom-kind-awarded-triple-crown/" rel="bookmark">Kingdom Kind awarded “Triple Crown”</a></h1>
		<p class="meta"><time datetime="2022-11-09T09:35:18-04:00">Published 1m ago</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>95 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-41662">
		<div class="caption">
		<h1 class="title"><a href="https://bartonchronicle.com/citizens-have-their-say-on-democracy/" rel="bookmark">Citizens have their say on democracy</a></h1>
		<p class="meta"><time datetime="2022-11-02T08:34:46-04:00">Published 1m ago</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>7 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-41627 cover">
			<div class="thumbnail">
			<a href="https://bartonchronicle.com/a-successful-hunt/" rel="bookmark"><img width="54" height="54" src="https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-54x54.jpg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-54x54.jpg 54w, https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-150x150.jpg 150w, https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-72x72.jpg 72w, https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-144x144.jpg 144w, https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-108x108.jpg 108w, https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-58x58.jpg 58w, https://bartonchronicle.com/wp-content/uploads/2022/10/front-garrett-deer-cmyk-116x116.jpg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41627&disabled=true&is_comment=false" class="tvote-button tvote-button-41627" data-nonce="a596fa3a79" data-post-id="41627" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://bartonchronicle.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://bartonchronicle.com/a-successful-hunt/" rel="bookmark">A successful hunt</a></h1>
		<p class="meta"><time datetime="2022-10-25T12:46:54-04:00">Published 2m ago</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>37 bookmarks</span></p>	</div>
</article><article class="post horiz-mini expt post-id-41623 cover">
			<div class="thumbnail">
			<a href="https://bartonchronicle.com/curtis-takes-a-doe/" rel="bookmark"><img width="54" height="54" src="https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-54x54.jpeg" class="attachment-times-horiz-mini size-times-horiz-mini wp-post-image" alt="" decoding="async" loading="lazy" srcset="https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-54x54.jpeg 54w, https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-150x150.jpeg 150w, https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-72x72.jpeg 72w, https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-144x144.jpeg 144w, https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-108x108.jpeg 108w, https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-58x58.jpeg 58w, https://bartonchronicle.com/wp-content/uploads/2022/10/kaylee-deer-e1666715873536-116x116.jpeg 116w" sizes="100vw" /></a>
			<div class="tvote-wrap small"><span class="button"><a href="https://bartonchronicle.com/wp-admin/admin-ajax.php?action=times_process_times_vote&nonce=a596fa3a79&post_id=41623&disabled=true&is_comment=false" class="tvote-button tvote-button-41623" data-nonce="a596fa3a79" data-post-id="41623" data-iscomment="false"></a><img class="bookmark-small svg-inject" src="https://bartonchronicle.com/wp-content/themes/times/img/bookmark-small.svg"></span><span class="context tooltip center-top"><span class="add">Bookmark?</span><span class="remove">Remove?</span></span></div>		</div>
		<div class="caption">
		<h1 class="title"><a href="https://bartonchronicle.com/curtis-takes-a-doe/" rel="bookmark">Curtis takes a doe</a></h1>
		<p class="meta"><time datetime="2022-10-25T12:38:27-04:00">Published 2m ago</time><span class="bookmarks"><span class="hyphen">&nbsp;-&nbsp;</span>45 bookmarks</span></p>	</div>
</article>			</section>
	
						<section class="desktop-widgets">
				<section id="text-6" class="widget bass widget_text">			<div class="textwidget"><p>[rp-news-ticker]</p>
</div>
		</section>			</section>
			
			
		</aside>

	</div>
	</div>

<footer class="site-footer basic-layout customizer-logo custom-layout column-count-4">
	<div class="row">

	
	<div class="widget-area col"></div><div class="widget-area col"><section id="text-7" class="widget bass widget_text"><h2 class="widget-title">About</h2>			<div class="textwidget"><p>The weekly journal of Orleans County, VT, since 1974.</p>
</div>
		</section></div><div class="widget-area col"><section id="nav_menu-3" class="widget bass widget_nav_menu"><div class="menu-bottom-container"><ul id="menu-bottom" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124"><a href="https://bartonchronicle.com/return-policy/">Return Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125"><a href="https://bartonchronicle.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16592"><a href="https://bartonchronicle.com/ad-rates/">Ad Rates</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16593"><a href="https://bartonchronicle.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16594"><a href="https://bartonchronicle.com/print-subscriptions/">Print Subscriptions</a></li>
</ul></div></section></div><div class="widget-area col"></div>
	</div>
	<div class="row">
		<div class="site-branding">
			<div class="col st5"><span class="aligner"></span><a href="https://bartonchronicle.com/" rel="home"><img width="" height="" src="https://bartonchronicle.com/wp-content/uploads/Chronicle-headline-compact-1.png" alt="Barton Chronicle Newspaper - Log in to read current news &amp; events"></a></div>
			<div class="col st10"><p class="footer-text-selective">© 2022. the Chronicle, Inc. All rights reserved.</p></div>
		</div>
	</div>
</footer><div id="times-legal-notice" data-times-countries="EU,EEA"><div class="notice-wrapper compact-notice horizontal show-icon"><div class="notice-content"><div class="notice-header"><div class="cookie-icon"></div><h3 class="notice-title">We use cookies!</h3></div><div class="notice-desc-box no-hy"><p>By <i>using this site</i> you agree to the use of cookies, <a href="/privacy-policy/">more info.</a></p></div><div class="notice-close notice-ok"><img src="https://bartonchronicle.com/wp-content/themes/times/img/close-12.svg" class="svg-inject close-svg" alt="Close notice icon"></div></div></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">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</script><script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wppas/public/assets/js/vbc/postscribe.min.js?ver=5.3.1' id='WPPAS_POSRBE-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.2' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.13.2' id='jquery-effects-core-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/jquery/ui/effect-shake.min.js?ver=1.13.2' id='jquery-effects-shake-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wppas/public/assets/js/vbc/jquery-ui-effects.min.js?ver=5.3.1' id='WPPAS_VBC_EF-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wppas/public/assets/js/dom-to-image.js?ver=5.3.1' id='WPPAS_DOMTOIMG-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/plugins/wppas/public/assets/js/vbc/jquery.wppas.vbc.min.js?ver=5.3.1' id='WPPAS_VBC-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/svg-injector.min.js?ver=1.1.3.1' id='SVGInjector-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/jquery.dotdotdot.min.js?ver=1.8.0.1' id='jquery-dotdotdot-min-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/jquery.hypher.min.js?ver=1.4.7' id='hypher-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/langs/en-us.min.js?ver=1.4.7' id='hypher-en-us-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/picturefill.min.js?ver=3.0.2.1' async='async' id='picturefill-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/js.cookie.min.js?ver=2.1.3.1' id='js-cookie-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='imagesloaded-js-after'>
(function ($) { "use strict"; $('#masthead .site-branding').imagesLoaded( function() { if ( $('#masthead .adele-wrap').length || $('#masthead .site-branding img').length ) {if (typeof scrollToContent !== 'undefined') scrollToContent();} }); })(jQuery);
</script>
<script type='text/javascript' id='times-scripts-js-before'>
var ajaxUrl="https://bartonchronicle.com/wp-admin/admin-ajax.php";var rootUrl="https://bartonchronicle.com/wp-content/themes/times";var siteLang="en";
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/times-scripts.min.js?ver=1.5.2' id='times-scripts-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/modernizr.build.min.js?ver=3.3.1.1' id='modernizr-backgroundcliptext-flexbox-setclasses-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/times-menu.min.js?ver=1.4.7' id='times-menu-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/unorphanize.jquery.min.js?ver=1.0.1.1' id='unorphanize-jquery-min-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/times-singular-scripts.min.js?ver=1.5.2' id='times-singular-scripts-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/times-single-standard-scripts.min.js?ver=1.4.7' id='times-single-scripts-js'></script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/skip-link-focus-fix.min.js?ver=201512151' async='async' id='_s-skip-link-focus-fix-js'></script>
<script type='text/javascript' id='times-vote-js-js-extra'>
/* <![CDATA[ */
var timesVotes = {"ajaxurl":"https:\/\/bartonchronicle.com\/wp-admin\/admin-ajax.php","like":"Like","unlike":"Unlike"};
/* ]]> */
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/times-vote.min.js?ver=2.3' id='times-vote-js-js'></script>
<script type='text/javascript' id='wp-postviews-cache-js-extra'>
/* <![CDATA[ */
var viewsCacheL10n = {"admin_ajax_url":"https:\/\/bartonchronicle.com\/wp-admin\/admin-ajax.php","post_id":"41967","transient":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://bartonchronicle.com/wp-content/themes/times/js/postviews-cache.min.js?ver=1.3.1' id='wp-postviews-cache-js'></script>

<script>(function(){var js = "window['__CF$cv$params']={r:'77a3e1953af381bd',m:'Uq_Gx2FfP_Owc2X1MCRJ2iiAN3waMUf0oIcEvSfVlxc-1671156611-0-AQhg5nAl6jV9/u8ZgKfYKpXIMbFKS8HDD7BYAK/pczbyId8wlrwoCubcFV40TXXBM6vFd6MFt5ZgH4gHKUlbDiJumjYHGqlF52MYHFF4l4Y5dA25tZ4FwfLLIryczz5oYnbLRKvFxYAhyiDD+UKRT44sCCET+nqzahPjVehIljcW',s:[0xc64096b552,0x7cb7a473f1],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>
